What browser and operating system are needed to use GetResponse? Watch video

GetResponse works on PCs and Macs. We are compatible with Windows, Mac OS and most browsers. We recommend latest Mozilla Firefox  and Chrome. To use the account on any mobile device please install our mobile app. We do not support old versions of Internet Explorer.

It is good to keep your browser up to date. If you think there is an issue with the browser – try deleting cache and cookies, watch the video below to learn how to do it. If this does not help, please contact us for further assistance.